Linux安全网 - Linux操作系统_Linux 命令_Linux教程_Linux黑客

会员投稿 投稿指南 本期推荐:
搜索:
您的位置: Linux安全网 > Linux安全 > » 正文

最新Linux下的溢出 一个命令搞定

来源: 未知 分享至:

因为机房硬件出现了严重故障,导致博客关系了近2周时间,真是抱歉,近来遇见一个关于webshell,需要获取到最高权限以进行一些其他操作,uname -r 之后的内核版本是2.6.9-34,相对而言版本算是比较低的了,可惜一直没有溢出成功,其中遇见的错误多为一些地址发现错误,没办法,对方主机上关闭了gcc,我从自己linux平台编译后移植过去的,看了下自己的linux版本2.6.23.1,还是溢出下自己试试吧!
本次尝试的是国外黑客taviso和julien公开德一个可以攻击所有新旧Linux系统漏洞,通杀几乎2.6.X的所有版本,如此神奇,当然得先测试下,可能文件太大我上传不了,直接贴地址:

http://www.securityfocus.com/data/vulnerabilities/exploits/wunderbar_emporium-3.tgz

由于是tgz的文件格式,可以通过wget url直接下载,然后再用tar -zxvf filename解压,解压后可以得到如下的4个文件:
 


 


现在我们可以转到该目录下执行./w*这个命令了,也就是是执行wunderbar_emporium.sh这个,我们来看看执行成功后的结果:
 


 


成功获取到root权限,赶紧去在webshell上测试去了。    转自:bre4k'blog

 


Tags: linux 溢出 最新 搞定
分享至:
最新图文资讯
1 2 3 4 5 6
验证码:点击我更换图片 理智评论文明上网,拒绝恶意谩骂 用户名:
关于我们 - 联系我们 - 广告服务 - 友情链接 - 网站地图 - 版权声明 - 发展历史