Problem Description
"OK, you are not too bad, em... But you can never pass the n
ext test." feng5166 says.
"I will tell you an o
dd number N, and then N integers. There will be a special integer among them, you have to tell me
which integer is the special one after I tell you all the integers." feng5166 says.
"But what is the characteristic of the special integer?" Ignatius asks.
"The integer will appear at least (N+1)/2
times. If you can't
find the right integer, I will
kill the Pri
ncess, and you will be my dinner, too. Hahahaha....." feng5166 says.
Can you find the special integer for Ignatius?
Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indi
cate the number of the integers feng5166 will tell our hero. The second line contains the
N integers. The input is te
rminat
ed by the end of
file.
Output
For each test case, you have to output only one line which contains the special number you have found.
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
Sample Output
3
5
1
题意:
先输入一个数n,接下来一行输入n个数,然后找出相同的数个数大于(n+1)/2的数.
代码:
#include<stdio.h>
#include<stdlib.h>
int comp(const void *a,const void *b)
{
return *(int *)a-*(int *)b;
}
int a[1000000];//数组定义的很大的时候在全局定义
int main()
{
int n,i;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
qsort(a,n,sizeof(int),comp);
printf("%d\n",a[(n-1)/2]);//求中位数
}
return 0;
}
分析:
很水的一道题啊,求比(n+1)/2还多的数,这个数排序完以后肯占所有的数一半还要多,没别的答案啦,就是中位数.
用冒泡排序的时候不知道会不会超时,但是自从学了快排以后,觉得比冒泡简单,速度还快没理由不用.